Install Tmux on Ubuntu

Download#

Download from http://tmux.sourceforge.net.

Install libevent-dev#

Ubuntu 9 or less#

Make sure you are install libevent 1.4 or greater. Ubuntu 9.04 comes with 1.3.

To download libevent directly, go to http://monkey.org/~provos/libevent/.

$ tar xvfz libevent-1.4.x-stable.tar.gz
$ cd libevent-1.4.x
$ ./configure
$ make
$ sudo make install
$ sudo /sbin/ldconfig

Install the curses development files

$ sudo apt-get install libncurses5-dev

Ubuntu 10 or great#

Install libevent-dev and libncurses-dev

$ sudo apt-get install libevent-dev libncurses5-dev

Build/Install Tmux#

$ ./configure
$ make
$ sudo make install

If you get an error saying

tmux: error while loading shared libraries: libeven-1.4.so.2: cannot open shared object file: No such file or directory

then you need to run

$ sudo /sbin/ldconfig

and it should work.


Linux.Shell - Linux.TerminalMultiplexer - Networking

Add new attachment

Only authorized users are allowed to upload new attachments.
« This page (revision-) was last changed on 01-Oct-2016 22:41 by UnknownAuthor